PPTP on IPXCore (OpenVZ) anybody has it working?

PPTP on IPXCore (OpenVZ) anybody has it working?

vahevahe Member
edited July 2012 in General

I've been trying to get VPN with pptp installed on the ipxcore vps for a while with no luck. I guess they support it since it can be enabled from the solusvm. I'm getting "A connection could not be established to the PPP server." on OSX. Has anybody got it working? Any advice on how to debug?

Tagged:

Comments

  • CiriumCirium Member
    edited July 2012

    This is due to a kernel module not enabled on openvz servers. (required by ppp)

    (Even though u enabled PPP, this still won't be enabled.)

    It is enabled on Xen and KVM servers by default. Which is alot easier than setting up a VPN on openvz servers in my opinion.

    Now I cant guarantee this is the problem, but its most likely the problem.

    To install this module, ask your host to enable PPP in your container. -Cirium

  • bretonbreton Member

    Welcome to the support forum of IPXCore!

  • Disable mppe as @Damian needs to enable that for PPTP's encryption to work. I can tell you that PPTP does work though.

    This signature is brought to you by the NSA. Spying on the entire world since 1952!

  • vahevahe Member

    @TheHackBox said: Disable mppe as @Damian needs to enable that for PPTP's encryption to work. I can tell you that PPTP does work though.

    Thanks! That did it!

  • maybe open a ticket and ask him to enable the mppe module, I've had another provider recently do this.

  • DamianDamian Member

    @vahe said: I've been trying to get VPN with pptp installed on the ipxcore vps for a while with no luck. I guess they support it since it can be enabled from the solusvm. I'm getting "A connection could not be established to the PPP server." on OSX. Has anybody got it working? Any advice on how to debug?

    I'd like to take a look and see why this didn't get resolved via support ticket for you (as you're posting it here). Can you please send me the ticket's #?

    @breton said: Welcome to the support forum of IPXCore!

    Yeah no kidding...

    I am no longer affiliated with IPXcore.
  • @Damian Enable ppp_mppe on sapphire and diamond.

    This signature is brought to you by the NSA. Spying on the entire world since 1952!

  • DamianDamian Member
    edited July 2012

    @TheHackBox said: Enable ppp_mppe on sapphire and diamond.

    Done and will now automatically load, too.

    I am no longer affiliated with IPXcore.
  • vahevahe Member

    @Damian said: I'd like to take a look and see why this didn't get resolved via support ticket for you (as you're posting it here). Can you please send me the ticket's #?

    Haven't submitted a ticket. This was my first time setting up over ppp, so I was thinking it was a problem on my side.

    @Damian said: Done and will now automatically load, too.

    Thanks!

Sign In or Register to comment.